<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Investors Catching Stocks Endologix, Inc.(NASDAQ:ELGX): Old Dominion Freight Line, Inc.(NASDAQ:ODFL)</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://www.newsoracle.com/xmlrpc.php" />
    <meta property="og:image" content="https://www.newsoracle.com/wp-content/uploads/2015/09/TA_COURSES_STOCKS1-1.png" /><meta name="author" content="Adam Smith">
<link rel="icon" type="image/png" href="https://www.newsoracle.com/wp-content/uploads/2016/12/NewsOraclefavicon-trans.png"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://nationalfinancial.fidelity.com/app/proxy/image?literatureURL=/RD_13569_43784/chart-trending-circle-lt-blue-136x136.png"/><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://nationalfinancial.fidelity.com/app/proxy/image?literatureURL=/RD_13569_43784/chart-trending-circle-lt-blue-136x136.png"/><link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://nationalfinancial.fidelity.com/app/proxy/image?literatureURL=/RD_13569_43784/chart-trending-circle-lt-blue-136x136.png"/><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://nationalfinancial.fidelity.com/app/proxy/image?literatureURL=/RD_13569_43784/chart-trending-circle-lt-blue-136x136.png"/><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://nationalfinancial.fidelity.com/app/proxy/image?literatureURL=/RD_13569_43784/chart-trending-circle-lt-blue-136x136.png"/>
<!-- All in One SEO Pack 2.10.1 by Michael Torbert of Semper Fi Web Design[213,334] -->
<meta name="description"  content="Endologix, Inc. (ELGX) will report its next earnings on Feb 05 AMC. The company reported the earnings of $-0.55/Share in the last quarter where the estimated" />

<link rel="canonical" href="https://www.newsoracle.com/2020/01/03/investors-catching-stocks-endologix-inc-nasdaqelgx-old-dominion-freight-line-inc-nasdaqodfl/" />
			<script type="text/javascript" >
				window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
				ga('create', 'UA-67463609-1', 'auto');
				// Plugins
				
				ga('send', 'pageview');
			</script>
			<script async src="https://www.google-analytics.com/analytics.js"></script>
			<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//www.newsoracle.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="News Oracle &raquo; Feed" href="https://www.newsoracle.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="News Oracle &raquo; Comments Feed" href="https://www.newsoracle.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="News Oracle &raquo; Investors Catching Stocks Endologix, Inc.(NASDAQ:ELGX): Old Dominion Freight Line, Inc.(NASDAQ:ODFL) Comments Feed" href="https://www.newsoracle.com/2020/01/03/investors-catching-stocks-endologix-inc-nasdaqelgx-old-dominion-freight-line-inc-nasdaqodfl/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.newsoracle.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.newsoracle.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://www.newsoracle.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_open_sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Montserrat%3A400%2C700%7CQuattrocento+Sans%3A400%2C700&#038;ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='https://www.newsoracle.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.12' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://www.newsoracle.com/wp-content/themes/Newspaper/style.css?ver=7.2' type='text/css' media='all' />
<script type='text/javascript' src='https://www.newsoracle.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.newsoracle.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://www.newsoracle.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.newsoracle.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.newsoracle.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='what are Analysts report about Polymet Mining Corp.(NYSE:PLM): Marinus Pharmaceuticals, Inc.(NASDAQ:MRNS)' href='https://www.newsoracle.com/2020/01/03/what-are-analysts-report-about-polymet-mining-corp-nyseplm-marinus-pharmaceuticals-inc-nasdaqmrns/' />
<link rel='next' title='Comprehensive Stock Analysis of Huntington Bancshares Incorporated(NASDAQ:HBAN): Nexgen Energy Ltd.(NYSE:NXE)' href='https://www.newsoracle.com/2020/01/03/comprehensive-stock-analysis-of-huntington-bancshares-incorporatednasdaqhban-nexgen-energy-ltd-nysenxe/' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://www.newsoracle.com/?p=462486' />
<link rel="alternate" type="application/json+oembed" href="https://www.newsoracle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.newsoracle.com%2F2020%2F01%2F03%2Finvestors-catching-stocks-endologix-inc-nasdaqelgx-old-dominion-freight-line-inc-nasdaqodfl%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.newsoracle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.newsoracle.com%2F2020%2F01%2F03%2Finvestors-catching-stocks-endologix-inc-nasdaqelgx-old-dominion-freight-line-inc-nasdaqodfl%2F&#038;format=xml" />
<!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://www.newsoracle.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://www.newsoracle.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="https:\/\/www.newsoracle.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.2";
var td_get_template_directory_uri="https:\/\/www.newsoracle.com\/wp-content\/themes\/Newspaper";
var tds_snap_menu="";
var tds_logo_on_sticky="";
var tds_header_style="12";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#0066bf";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-2041800419917913",
    enable_page_level_ads: true
  });
</script>

<script async type="text/javascript" src="//s.clickiocdn.com/t/pb205464.js"></script>
<script async type="text/javascript" src="//s.clickiocdn.com/t/common_258.js"></script>

</head>

<body class="post-template-default single single-post postid-462486 single-format-standard investors-catching-stocks-endologix-inc-nasdaqelgx-old-dominion-freight-line-inc-nasdaqodfl wpb-js-composer js-comp-ver-4.12 vc_responsive td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/newsoracle/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-container"><ul id="menu-main" class="td-mobile-main-menu"><li id="menu-item-94060" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first menu-item-94060"><a href="https://www.newsoracle.com/">Home</a></li>
<li id="menu-item-1257" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1257"><a href="https://www.newsoracle.com/category/business/">Business</a></li>
<li id="menu-item-170309" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-170309"><a href="https://www.newsoracle.com/contacts/">Contact</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://www.newsoracle.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap">
    
        <!--
Header style 12
-->

<div class="td-header-wrap td-header-style-12">

	<div class="td-header-menu-wrap-full">
		<div class="td-header-menu-wrap td-header-gradient">
			<div class="td-container td-header-row td-header-main-menu">
				<div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-disable" href="https://www.newsoracle.com/">
			<img class="td-retina-data" data-retina="https://nationalfinancial.fidelity.com/app/proxy/image?literatureURL=/RD_13569_43784/chart-trending-circle-lt-blue-136x136.png" src="https://nationalfinancial.fidelity.com/app/proxy/image?literatureURL=/RD_13569_43784/chart-trending-circle-lt-blue-136x136.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-disable" href="https://www.newsoracle.com/">
			<img class="td-retina-data" data-retina="https://www.newsoracle.com/wp-content/uploads/2016/12/NewsOracleLogo-partialNegative-618x163-300x79.png" src="https://www.newsoracle.com/wp-content/uploads/2016/12/NewsOracleLogo-partialNegative-618x163-300x79.png" alt=""/>
			<span class="td-visual-hidden">News Oracle</span>
		</a>
	    </div>
    <div class="menu-main-container"><ul id="menu-main-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-94060"><a href="https://www.newsoracle.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-1257"><a href="https://www.newsoracle.com/category/business/">Business</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-170309"><a href="https://www.newsoracle.com/contacts/">Contact</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="https://www.newsoracle.com/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>			</div>
		</div>
	</div>

	<div class="td-header-top-menu-full">
		<div class="td-container td-header-row td-header-top-menu">
            <!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <ul class="td-login-tabs">
                        <li><a id="login-link" class="td_login_tab_focus">LOG IN</a></li>
                    </ul>



                    <div class="td-login-wrap">
                        <div class="td_display_err"></div>

                        <div id="td-login-div" class="">
                            <div class="td-login-panel-title">Welcome! Log into your account</div>
                            <input class="td-login-input" type="text" name="login_email" id="login_email" placeholder="your username" value="" required>
                            <input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" placeholder="your password" required>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Log In">


                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password?</a></div>


                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-display-none">
                            <div class="td-login-panel-title">Recover your password</div>
                            <input class="td-login-input" type="text" name="forgot_email" id="forgot_email" placeholder="your email" value="" required>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Pass">
                        </div>




                    </div>
                </div>
                		</div>
	</div>

	<div class="td-header-header-full td-banner-wrap-full">
		<div class="td-container-header td-header-row td-header-header">
			<div class="td-header-sp-recs">
				<div class="td-header-rec-wrap">
    
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-header ">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-2041800419917913" data-ad-slot="2584125385"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2041800419917913" data-ad-slot="2584125385"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2041800419917913" data-ad-slot="2584125385"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-2041800419917913" data-ad-slot="2584125385"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 


</div>			</div>
		</div>
	</div>

</div><div class="td-main-content-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-462486" class="post-462486 post type-post status-publish format-standard has-post-thumbnail hentry category-business" itemscope itemtype="https://schema.org/Article">
        <div class="td-post-header">

            <ul class="td-category"><li class="entry-category"><a  href="https://www.newsoracle.com/category/business/">Business</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Investors Catching Stocks Endologix, Inc.(NASDAQ:ELGX): Old Dominion Freight Line, Inc.(NASDAQ:ODFL)</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name">By <a href="https://www.newsoracle.com/author/adam-smith/">Adam Smith</a> - </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-01-03T17:06:44+00:00" >Jan 3, 2020</time></span>                    <div class="td-post-comments"><a href="https://www.newsoracle.com/2020/01/03/investors-catching-stocks-endologix-inc-nasdaqelgx-old-dominion-freight-line-inc-nasdaqodfl/#respond"><i class="td-icon-comments"></i>0</a></div>                    <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-462486">0</span></div>                </div>

            </header>

        </div>

        

        <div class="td-post-content">

        <div class="td-post-featured-image"><img width="696" height="522" class="entry-thumb" src="https://www.newsoracle.com/wp-content/uploads/2016/06/Stocks-696x522.jpg" alt="" title="Stocks"/></div>
        
<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-2041800419917913"
     data-ad-slot="5460857788"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<div id="contentad298456"></div>
<script type="text/javascript">
    (function(d) {
        var params =
        {
            id: "5a248f9d-3753-4a4c-8809-e9680b3b6e09",
            d:  "bmV3c29yYWNsZS5jb20=",
            wid: "298456",
            cb: (new Date()).getTime()
        };

        var qs=[];
        for(var key in params) qs.push(key+'='+encodeURIComponent(params[key]));
        var s = d.createElement('script');s.type='text/javascript';s.async=true;
        var p = 'https:' == document.location.protocol ? 'https' : 'http';
        s.src = p + "://api.content-ad.net/Scripts/widget2.aspx?" + qs.join('&');
        d.getElementById("contentad298456").appendChild(s);
    })(document);
</script>
</div>

 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_inline ">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2041800419917913" data-ad-slot="4867574186"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2041800419917913" data-ad-slot="4867574186"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2041800419917913" data-ad-slot="4867574186"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-2041800419917913" data-ad-slot="4867574186"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

<p>Endologix, Inc. (ELGX) will report its next earnings on Feb 05 AMC. The company reported the earnings of $-0.55/Share in the last quarter where the estimated EPS by analysts was $-0.72/share. The difference between the expected and actual EPS was $0.17/share, which represents an Earnings surprise of 23.6%.</p>
<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div style="float: left; margin: 10px 10px 10px 0;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- NewsOracle 300x600 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-2041800419917913"
     data-ad-slot="4864907789"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<p>Many analysts are providing their Estimated Earnings analysis for Endologix, Inc. and for the current quarter 7 analysts have projected that the stock could give an Average Earnings estimate of $-0.68/share. These analysts have also projected a Low Estimate of $-0.99/share and a High Estimate of $-0.42/share.</p>
<p>In case of Revenue Estimates, 7 analysts have provided their consensus Average Revenue Estimates for Endologix, Inc. as 34.34 Million. According to these analysts, the Low Revenue Estimate for Endologix, Inc. is 33.5 Million and the High Revenue Estimate is 35.7 Million. The company had Year Ago Sales of 34.69 Million.</p>
<p>These analysts also forecasted Growth Estimates for the Current Quarter for ELGX to be 66.7%. They are projecting Next Quarter growth of 58.04%. For the next 5 years, Endologix, Inc. is expecting Growth of 32.12% per annum, whereas in the past 5 years the growth was 60.97% per annum.</p>
<p>Some buy side analysts are also providing their Analysis on Endologix, Inc., where 0 analysts have rated the stock as Strong buy, 0 analysts have given a Buy signal, 1 said it&#8217;s a HOLD, and 0 analysts rated the stock as Sell. (These Recommendations are for the Current Month Only reported by Yahoo Finance.)</p>
<p>The Relative Volume of the company is 2 and Average Volume (3 months) is 173.46 million. The company&#8217;s P/E (price to earnings) ratio is 0 and Forward P/E ratio of 0.</p>
<p>The company shows its Return on Assets (ROA) value of -27.1%. The Return on Equity (ROE) value stands at -165%. While it&#8217;s Return on Investment (ROI) value is -26.8%.</p>
<p>While looking at the Stock&#8217;s Performance, Endologix, Inc. currently shows a Weekly Performance of 2.15%, where Monthly Performance is -25.49%, Quarterly performance is -42.77%, 6 Months performance is -74.77% and yearly performance percentage is -74.32%. Year to Date performance value (YTD perf) value is 20.25%. The Stock currently has a Weekly Volatility of 9.80% and Monthly Volatility of 9.53%.</p>
<p>Old Dominion Freight Line, Inc. (ODFL) will report its next earnings on Jan 23 BMO. The company reported the earnings of $2.05/Share in the last quarter where the estimated EPS by analysts was $2.11/share. The difference between the expected and actual EPS was $-0.06/share, which represents an Earnings surprise of -2.8%.</p>
<p>Many analysts are providing their Estimated Earnings analysis for Old Dominion Freight Line, Inc. and for the current quarter 14 analysts have projected that the stock could give an Average Earnings estimate of $1.83/share. These analysts have also projected a Low Estimate of $1.72/share and a High Estimate of $1.88/share.</p>
<p>In case of Revenue Estimates, 10 analysts have provided their consensus Average Revenue Estimates for Old Dominion Freight Line, Inc. as 1.01 Billion. According to these analysts, the Low Revenue Estimate for Old Dominion Freight Line, Inc. is 990 Million and the High Revenue Estimate is 1.04 Billion. The company had Year Ago Sales of 1.03 Billion.</p>
<p>These analysts also forecasted Growth Estimates for the Current Quarter for ODFL to be -6.2%. They are projecting Next Quarter growth of 4.88%. For the next 5 years, Old Dominion Freight Line, Inc. is expecting Growth of 10.51% per annum, whereas in the past 5 years the growth was 4.2% per annum.</p>
<p>Some buy side analysts are also providing their Analysis on Old Dominion Freight Line, Inc., where 1 analysts have rated the stock as Strong buy, 0 analysts have given a Buy signal, 2 said it&#8217;s a HOLD, and 0 analysts rated the stock as Sell. (These Recommendations are for the Current Month Only reported by Yahoo Finance.)</p>
<p>The Relative Volume of the company is 0.88 and Average Volume (3 months) is 729.82 million. The company&#8217;s P/E (price to earnings) ratio is 24.59 and Forward P/E ratio of 22.79.</p>
<p>The company shows its Return on Assets (ROA) value of 16.9%. The Return on Equity (ROE) value stands at 22.6%. While it&#8217;s Return on Investment (ROI) value is 22.3%.</p>

<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div style="float: none; margin:0px;">
<iframe valign="middle" width="100%" height="300" marginheight=0 marginwidth=0 frameborder=0 vspace=0 hspace=0 scrolling=NO  src="//www.dianomi.com/smartads.epl?id=2699"></iframe>
</div>
<p>While looking at the Stock&#8217;s Performance, Old Dominion Freight Line, Inc. currently shows a Weekly Performance of 2.15%, where Monthly Performance is 3.09%, Quarterly performance is 18.72%, 6 Months performance is 28.42% and yearly performance percentage is 55.59%. Year to Date performance value (YTD perf) value is 1.19%. The Stock currently has a Weekly Volatility of 1.19% and Monthly Volatility of 1.72%.</p>

<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-2041800419917913"
     data-ad-slot="5460857788"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<div id="contentad298456"></div>
<script type="text/javascript">
    (function(d) {
        var params =
        {
            id: "5a248f9d-3753-4a4c-8809-e9680b3b6e09",
            d:  "bmV3c29yYWNsZS5jb20=",
            wid: "298456",
            cb: (new Date()).getTime()
        };

        var qs=[];
        for(var key in params) qs.push(key+'='+encodeURIComponent(params[key]));
        var s = d.createElement('script');s.type='text/javascript';s.async=true;
        var p = 'https:' == document.location.protocol ? 'https' : 'http';
        s.src = p + "://api.content-ad.net/Scripts/widget2.aspx?" + qs.join('&');
        d.getElementById("contentad298456").appendChild(s);
    })(document);
</script>
</div>

<div style="font-size: 0px; height: 0px; line-height: 0px; margin: 0; padding: 0; clear: both;"></div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                            </div>

            <div class="td-post-sharing td-post-sharing-bottom td-with-like"><span class="td-post-share-title">SHARE</span>
            <div class="td-default-sharing">
	            <a class="td-social-sharing-buttons td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.newsoracle.com%2F2020%2F01%2F03%2Finvestors-catching-stocks-endologix-inc-nasdaqelgx-old-dominion-freight-line-inc-nasdaqodfl%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Facebook</div></a>
	            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Investors+Catching+Stocks+Endologix%2C+Inc.%28NASDAQ%3AELGX%29%3A+Old+Dominion+Freight+Line%2C+Inc.%28NASDAQ%3AODFL%29&url=https%3A%2F%2Fwww.newsoracle.com%2F2020%2F01%2F03%2Finvestors-catching-stocks-endologix-inc-nasdaqelgx-old-dominion-freight-line-inc-nasdaqodfl%2F&via=newsoracle_com"><i class="td-icon-twitter"></i><div class="td-social-but-text">Twitter</div></a>
	            <a class="td-social-sharing-buttons td-social-google" href="https://plus.google.com/share?url=https://www.newsoracle.com/2020/01/03/investors-catching-stocks-endologix-inc-nasdaqelgx-old-dominion-freight-line-inc-nasdaqodfl/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
	            <a class="td-social-sharing-buttons td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.newsoracle.com/2020/01/03/investors-catching-stocks-endologix-inc-nasdaqelgx-old-dominion-freight-line-inc-nasdaqodfl/&amp;media=https://www.newsoracle.com/wp-content/uploads/2015/09/MW-BS738_green__MG_20140116132516-1-boost.jpg&description=Investors+Catching+Stocks+Endologix%2C+Inc.%28NASDAQ%3AELGX%29%3A+Old+Dominion+Freight+Line%2C+Inc.%28NASDAQ%3AODFL%29" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
	            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Investors+Catching+Stocks+Endologix%2C+Inc.%28NASDAQ%3AELGX%29%3A+Old+Dominion+Freight+Line%2C+Inc.%28NASDAQ%3AODFL%29%20-%20https%3A%2F%2Fwww.newsoracle.com%2F2020%2F01%2F03%2Finvestors-catching-stocks-endologix-inc-nasdaqelgx-old-dominion-freight-line-inc-nasdaqodfl%2F" ><i class="td-icon-whatsapp"></i></a>
            </div><div class="td-classic-sharing"><ul><li class="td-classic-facebook"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://www.newsoracle.com/2020/01/03/investors-catching-stocks-endologix-inc-nasdaqelgx-old-dominion-freight-line-inc-nasdaqodfl/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></li><li class="td-classic-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://www.newsoracle.com/2020/01/03/investors-catching-stocks-endologix-inc-nasdaqelgx-old-dominion-freight-line-inc-nasdaqodfl/" data-text="Investors Catching Stocks Endologix, Inc.(NASDAQ:ELGX): Old Dominion Freight Line, Inc.(NASDAQ:ODFL)" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li></ul></div></div>                        <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://www.newsoracle.com/author/adam-smith/">Adam Smith</a></span></div>	        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Adam Smith"></span><meta itemprop="datePublished" content="2020-01-03T17:06:44+00:00"><meta itemprop="dateModified" content="2020-01-03T17:06:44+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.newsoracle.com/2020/01/03/investors-catching-stocks-endologix-inc-nasdaqelgx-old-dominion-freight-line-inc-nasdaqodfl/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.newsoracle.com/wp-content/uploads/2016/12/NewsOracleLogo-partialNegative-618x163-300x79.png"></span><meta itemprop="name" content="News Oracle"></span><meta itemprop="headline " content="Investors Catching Stocks Endologix, Inc.(NASDAQ:ELGX): Old Dominion Freight Line, Inc.(NASDAQ:ODFL)"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.newsoracle.com/wp-content/uploads/2015/09/179077258.jpg"><meta itemprop="width" content="680"><meta itemprop="height" content="440"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts td_uid_3_5e0f74dc5faad_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_3_5e0f74dc5faad" ><script>var block_td_uid_3_5e0f74dc5faad = new tdBlock();
block_td_uid_3_5e0f74dc5faad.id = "td_uid_3_5e0f74dc5faad";
block_td_uid_3_5e0f74dc5faad.atts = '{"limit":3,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_3_5e0f74dc5faad_rand","offset":"","css":"","live_filter":"cur_post_same_categories","live_filter_cur_post_id":462486,"live_filter_cur_post_author":"9"}';
block_td_uid_3_5e0f74dc5faad.td_column_number = "3";
block_td_uid_3_5e0f74dc5faad.block_type = "td_block_related_posts";
block_td_uid_3_5e0f74dc5faad.post_count = "3";
block_td_uid_3_5e0f74dc5faad.found_posts = "172466";
block_td_uid_3_5e0f74dc5faad.header_color = "";
block_td_uid_3_5e0f74dc5faad.ajax_pagination_infinite_stop = "";
block_td_uid_3_5e0f74dc5faad.max_num_pages = "57489";
tdBlocksArray.push(block_td_uid_3_5e0f74dc5faad);
</script><h4 class="td-related-title"><a id="td_uid_4_5e0f74df57af3" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_3_5e0f74dc5faad" href="#">RELATED ARTICLES</a><a id="td_uid_5_5e0f74df57b31" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_3_5e0f74dc5faad" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_3_5e0f74dc5faad class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.newsoracle.com/2020/01/03/comprehensive-stock-analysis-of-huntington-bancshares-incorporatednasdaqhban-nexgen-energy-ltd-nysenxe/" rel="bookmark" title="Comprehensive Stock Analysis of Huntington Bancshares Incorporated(NASDAQ:HBAN): Nexgen Energy Ltd.(NYSE:NXE)"><img width="218" height="150" class="entry-thumb" src="https://www.newsoracle.com/wp-content/uploads/2015/09/market_2547067b-1-218x150.jpg" alt="" title="Comprehensive Stock Analysis of Huntington Bancshares Incorporated(NASDAQ:HBAN): Nexgen Energy Ltd.(NYSE:NXE)"/></a></div>                <a href="https://www.newsoracle.com/category/business/" class="td-post-category">Business</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.newsoracle.com/2020/01/03/comprehensive-stock-analysis-of-huntington-bancshares-incorporatednasdaqhban-nexgen-energy-ltd-nysenxe/" rel="bookmark" title="Comprehensive Stock Analysis of Huntington Bancshares Incorporated(NASDAQ:HBAN): Nexgen Energy Ltd.(NYSE:NXE)">Comprehensive Stock Analysis of Huntington Bancshares Incorporated(NASDAQ:HBAN): Nexgen Energy Ltd.(NYSE:NXE)</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.newsoracle.com/2020/01/03/what-are-analysts-report-about-polymet-mining-corp-nyseplm-marinus-pharmaceuticals-inc-nasdaqmrns/" rel="bookmark" title="what are Analysts report about Polymet Mining Corp.(NYSE:PLM): Marinus Pharmaceuticals, Inc.(NASDAQ:MRNS)"><img width="218" height="150" class="entry-thumb" src="https://www.newsoracle.com/wp-content/uploads/2016/06/swing-trading-stocks2-218x150.jpg" alt="" title="what are Analysts report about Polymet Mining Corp.(NYSE:PLM): Marinus Pharmaceuticals, Inc.(NASDAQ:MRNS)"/></a></div>                <a href="https://www.newsoracle.com/category/business/" class="td-post-category">Business</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.newsoracle.com/2020/01/03/what-are-analysts-report-about-polymet-mining-corp-nyseplm-marinus-pharmaceuticals-inc-nasdaqmrns/" rel="bookmark" title="what are Analysts report about Polymet Mining Corp.(NYSE:PLM): Marinus Pharmaceuticals, Inc.(NASDAQ:MRNS)">what are Analysts report about Polymet Mining Corp.(NYSE:PLM): Marinus Pharmaceuticals, Inc.(NASDAQ:MRNS)</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.newsoracle.com/2020/01/03/what-are-analysts-suggestions-on-docusign-inc-nasdaqdocu-freeport-mcmoran-inc-nysefcx/" rel="bookmark" title="What are analysts Suggestions on DocuSign, Inc.(NASDAQ:DOCU): Freeport-McMoran, Inc.(NYSE:FCX)"><img width="218" height="150" class="entry-thumb" src="https://www.newsoracle.com/wp-content/uploads/2015/09/Crash-1-218x150.jpg" alt="" title="What are analysts Suggestions on DocuSign, Inc.(NASDAQ:DOCU): Freeport-McMoran, Inc.(NYSE:FCX)"/></a></div>                <a href="https://www.newsoracle.com/category/business/" class="td-post-category">Business</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.newsoracle.com/2020/01/03/what-are-analysts-suggestions-on-docusign-inc-nasdaqdocu-freeport-mcmoran-inc-nysefcx/" rel="bookmark" title="What are analysts Suggestions on DocuSign, Inc.(NASDAQ:DOCU): Freeport-McMoran, Inc.(NYSE:FCX)">What are analysts Suggestions on DocuSign, Inc.(NASDAQ:DOCU): Freeport-McMoran, Inc.(NYSE:FCX)</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5e0f74dc5faad" data-td_block_id="td_uid_3_5e0f74dc5faad"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_5e0f74dc5faad" data-td_block_id="td_uid_3_5e0f74dc5faad"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

	<div class="comments" id="comments">
            </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside class="widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-2041800419917913"
     data-ad-slot="5460857788"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><iframe valign="middle" marginheight=0 marginwidth=0 frameborder=0 vspace=0 hspace=0 scrolling=NO  src="//www.dianomi.com/smartads.epl?id=2700"></iframe></div>
		</aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Ad Clerks Shopping Cart -->
<script src="https://adclerks.com/assets/js/cart.js" data-site="6539" id="pc_site"></script>

<!-- Instagram -->



<!-- Footer -->
<div class="td-footer-wrapper">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_7 td_uid_7_5e0f74df5b0be_rand td-pb-border-top"  data-td-block-uid="td_uid_7_5e0f74df5b0be" ><script>var block_td_uid_7_5e0f74df5b0be = new tdBlock();
block_td_uid_7_5e0f74df5b0be.id = "td_uid_7_5e0f74df5b0be";
block_td_uid_7_5e0f74df5b0be.atts = '{"limit":3,"sort":"featured","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"EDITOR PICKS","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_7_5e0f74df5b0be_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_7_5e0f74df5b0be.td_column_number = "1";
block_td_uid_7_5e0f74df5b0be.block_type = "td_block_7";
block_td_uid_7_5e0f74df5b0be.post_count = "3";
block_td_uid_7_5e0f74df5b0be.found_posts = "173452";
block_td_uid_7_5e0f74df5b0be.header_color = "";
block_td_uid_7_5e0f74df5b0be.ajax_pagination_infinite_stop = "";
block_td_uid_7_5e0f74df5b0be.max_num_pages = "57818";
tdBlocksArray.push(block_td_uid_7_5e0f74df5b0be);
</script><h4 class="block-title"><span>EDITOR PICKS</span></h4><div id=td_uid_7_5e0f74df5b0be class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.newsoracle.com/2020/01/03/comprehensive-stock-analysis-of-huntington-bancshares-incorporatednasdaqhban-nexgen-energy-ltd-nysenxe/" rel="bookmark" title="Comprehensive Stock Analysis of Huntington Bancshares Incorporated(NASDAQ:HBAN): Nexgen Energy Ltd.(NYSE:NXE)"><img width="100" height="70" class="entry-thumb" src="https://www.newsoracle.com/wp-content/uploads/2015/09/TA_COURSES_STOCKS1-1-100x70.png" alt="" title="Comprehensive Stock Analysis of Huntington Bancshares Incorporated(NASDAQ:HBAN): Nexgen Energy Ltd.(NYSE:NXE)"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.newsoracle.com/2020/01/03/comprehensive-stock-analysis-of-huntington-bancshares-incorporatednasdaqhban-nexgen-energy-ltd-nysenxe/" rel="bookmark" title="Comprehensive Stock Analysis of Huntington Bancshares Incorporated(NASDAQ:HBAN): Nexgen Energy Ltd.(NYSE:NXE)">Comprehensive Stock Analysis of Huntington Bancshares Incorporated(NASDAQ:HBAN): Nexgen Energy Ltd.(NYSE:NXE)</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-01-03T17:06:47+00:00" >Jan 3, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.newsoracle.com/2020/01/03/investors-catching-stocks-endologix-inc-nasdaqelgx-old-dominion-freight-line-inc-nasdaqodfl/" rel="bookmark" title="Investors Catching Stocks Endologix, Inc.(NASDAQ:ELGX): Old Dominion Freight Line, Inc.(NASDAQ:ODFL)"><img width="100" height="70" class="entry-thumb" src="https://www.newsoracle.com/wp-content/uploads/2016/06/stock_market_chart-100x70.jpg" alt="" title="Investors Catching Stocks Endologix, Inc.(NASDAQ:ELGX): Old Dominion Freight Line, Inc.(NASDAQ:ODFL)"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.newsoracle.com/2020/01/03/investors-catching-stocks-endologix-inc-nasdaqelgx-old-dominion-freight-line-inc-nasdaqodfl/" rel="bookmark" title="Investors Catching Stocks Endologix, Inc.(NASDAQ:ELGX): Old Dominion Freight Line, Inc.(NASDAQ:ODFL)">Investors Catching Stocks Endologix, Inc.(NASDAQ:ELGX): Old Dominion Freight Line, Inc.(NASDAQ:ODFL)</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-01-03T17:06:44+00:00" >Jan 3, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.newsoracle.com/2020/01/03/what-are-analysts-report-about-polymet-mining-corp-nyseplm-marinus-pharmaceuticals-inc-nasdaqmrns/" rel="bookmark" title="what are Analysts report about Polymet Mining Corp.(NYSE:PLM): Marinus Pharmaceuticals, Inc.(NASDAQ:MRNS)"><img width="100" height="70" class="entry-thumb" src="https://www.newsoracle.com/wp-content/uploads/2016/06/Stock-market-100x70.jpg" alt="" title="what are Analysts report about Polymet Mining Corp.(NYSE:PLM): Marinus Pharmaceuticals, Inc.(NASDAQ:MRNS)"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.newsoracle.com/2020/01/03/what-are-analysts-report-about-polymet-mining-corp-nyseplm-marinus-pharmaceuticals-inc-nasdaqmrns/" rel="bookmark" title="what are Analysts report about Polymet Mining Corp.(NYSE:PLM): Marinus Pharmaceuticals, Inc.(NASDAQ:MRNS)">what are Analysts report about Polymet Mining Corp.(NYSE:PLM): Marinus Pharmaceuticals, Inc.(NASDAQ:MRNS)</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-01-03T17:06:41+00:00" >Jan 3, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->                            </div>

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_7 td_uid_8_5e0f74dff2678_rand td-pb-border-top"  data-td-block-uid="td_uid_8_5e0f74dff2678" ><script>var block_td_uid_8_5e0f74dff2678 = new tdBlock();
block_td_uid_8_5e0f74dff2678.id = "td_uid_8_5e0f74dff2678";
block_td_uid_8_5e0f74dff2678.atts = '{"limit":3,"sort":"popular","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"POPULAR POSTS","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_8_5e0f74dff2678_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_8_5e0f74dff2678.td_column_number = "1";
block_td_uid_8_5e0f74dff2678.block_type = "td_block_7";
block_td_uid_8_5e0f74dff2678.post_count = "3";
block_td_uid_8_5e0f74dff2678.found_posts = "173452";
block_td_uid_8_5e0f74dff2678.header_color = "";
block_td_uid_8_5e0f74dff2678.ajax_pagination_infinite_stop = "";
block_td_uid_8_5e0f74dff2678.max_num_pages = "57818";
tdBlocksArray.push(block_td_uid_8_5e0f74dff2678);
</script><h4 class="block-title"><span>POPULAR POSTS</span></h4><div id=td_uid_8_5e0f74dff2678 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.newsoracle.com/2017/01/11/analysts-recommendations-enteromedics-inc-nasdaqetrm-2/" rel="bookmark" title="analysts Recommendations: EnteroMedics Inc. (NASDAQ:ETRM)"><img width="100" height="70" class="entry-thumb" src="https://www.newsoracle.com/wp-content/uploads/2015/09/bg-1-100x70.jpg" alt="" title="analysts Recommendations: EnteroMedics Inc. (NASDAQ:ETRM)"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.newsoracle.com/2017/01/11/analysts-recommendations-enteromedics-inc-nasdaqetrm-2/" rel="bookmark" title="analysts Recommendations: EnteroMedics Inc. (NASDAQ:ETRM)">analysts Recommendations: EnteroMedics Inc. (NASDAQ:ETRM)</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-01-11T08:28:29+00:00" >Jan 11, 2017</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.newsoracle.com/2016/07/26/analysis-under-consideration-sophiris-bio-inc-nasdaqsphs/" rel="bookmark" title="Analysis under consideration: Sophiris Bio, Inc. (NASDAQ:SPHS)"><img width="100" height="70" class="entry-thumb" src="https://www.newsoracle.com/wp-content/uploads/2016/06/Stocks-100x70.jpg" alt="" title="Analysis under consideration: Sophiris Bio, Inc. (NASDAQ:SPHS)"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.newsoracle.com/2016/07/26/analysis-under-consideration-sophiris-bio-inc-nasdaqsphs/" rel="bookmark" title="Analysis under consideration: Sophiris Bio, Inc. (NASDAQ:SPHS)">Analysis under consideration: Sophiris Bio, Inc. (NASDAQ:SPHS)</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-07-26T11:56:21+00:00" >Jul 26, 2016</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.newsoracle.com/2016/09/12/comprehensive-stock-analysis-of-halcon-resources-corporation-nysehk/" rel="bookmark" title="Comprehensive Stock Analysis of: Halcon Resources Corporation (NYSE:HK)"><img width="100" height="70" class="entry-thumb" src="https://www.newsoracle.com/wp-content/uploads/2016/06/stock_market_chart-100x70.jpg" alt="" title="Comprehensive Stock Analysis of: Halcon Resources Corporation (NYSE:HK)"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.newsoracle.com/2016/09/12/comprehensive-stock-analysis-of-halcon-resources-corporation-nysehk/" rel="bookmark" title="Comprehensive Stock Analysis of: Halcon Resources Corporation (NYSE:HK)">Comprehensive Stock Analysis of: Halcon Resources Corporation (NYSE:HK)</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-09-12T09:55:55+00:00" >Sep 12, 2016</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->                            </div>

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_popular_categories td_uid_9_5e0f74e52420c_rand widget widget_categories td-pb-border-top"  data-td-block-uid="td_uid_9_5e0f74e52420c" ><h4 class="block-title"><span>POPULAR CATEGORY</span></h4><ul class="td-pb-padding-side"><li><a href="https://www.newsoracle.com/category/business/">Business<span class="td-cat-no">172467</span></a></li><li><a href="https://www.newsoracle.com/category/stocks/">Stocks<span class="td-cat-no">859</span></a></li><li><a href="https://www.newsoracle.com/category/life-style/">Life Style<span class="td-cat-no">1</span></a></li><li><a href="https://www.newsoracle.com/category/insider-trading/">Insider Trading<span class="td-cat-no">0</span></a></li></ul></div> <!-- ./block -->                            </div>
        </div>
    </div>
    <div class="td-footer-bottom-full">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://www.newsoracle.com/"><img class="td-retina-data" src="https://www.newsoracle.com/wp-content/uploads/2016/12/NewsOracleLogo-partialNegative-618x163-300x79.png" data-retina="https://www.newsoracle.com/wp-content/uploads/2016/12/NewsOracleLogo-partialNegative-618x163-300x79.png" alt="" title=""/></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>News Oracle is an online financial news outlet covering the most relevant financial news from around the globe including stocks, shares, forex and business news.</aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/newsoracle/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span></aside></div>            </div>
        </div>
    </div>
</div>

<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-footer-container"><ul id="menu-footer" class="td-subfooter-menu"><li id="menu-item-93726" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-93726"><a href="https://www.newsoracle.com/">Home</a></li>
<li id="menu-item-93728" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-93728"><a href="https://www.newsoracle.com/advertising/">Advertise with Us</a></li>
<li id="menu-item-93727" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-93727"><a href="https://www.newsoracle.com/contacts/">About Us &#038; How To Contact Us</a></li>
<li id="menu-item-93730" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-93730"><a href="https://www.newsoracle.com/privacy-policy/">Privacy Policy</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; Copyright News Oracle                </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->



    <!--

        Theme: Newspaper by tagDiv 2016
        Version: 7.2 (rara)
        Deploy mode: deploy
        
        uid: 5e0f74e527222
    -->

    
<!-- Custom css form theme panel -->
<style type="text/css" media="screen">
/* custom css theme panel */
.author-box-wrap .avatar {
    float: left;
    width: 100px;
    border-radius: 50%;
}

.td-post-content p, .td-post-content {
    font-weight: 300;
}
</style>

<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.newsoracle.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.newsoracle.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.1'></script>
<script type='text/javascript' src='https://www.newsoracle.com/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=7.2'></script>
<script type='text/javascript' src='https://www.newsoracle.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://www.newsoracle.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>

<!-- JS generated by theme -->

<script>
    

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[462486]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://www.newsoracle.com/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://www.newsoracle.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>


</body>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>
</html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 106/126 objects using disk
Page Caching using disk 
Database Caching 11/28 queries in 8.725 seconds using disk

Served from: newsoracle.com @ 2020-01-03 17:07:49 by W3 Total Cache
-->